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[bookmark: _Toc512796777]PART 1: Main Content

Whether you are creating a new spreadsheet or publishing a spreadsheet that someone else created, use the following checklist to ensure that the main content of the spreadsheet is accessible.
[bookmark: _Toc512796778][image: ]PART 1 Checklist
1. Fonts:   Use accessible fonts and set the zoom to 100%.
2. Tables:  Make sure tables are simple grids with simple headers, one per sheet.
3. Charts:   Make sure charts are well labeled and described, with one per sheet.
4. Color:    Make sure any use of color is accessible.
5. Other:    Check other types of content for accessibility.
[bookmark: _Toc512796779]
1. FONTS: Use accessible fonts and set the zoom to 100%.
Use a sans serif font size 12 or larger so that the text is large enough and readable for users with screen magnifiers. Serif fonts become blurry when magnified. It is valuable to set fonts early on in order to avoid additional reformatting later.

[bookmark: _Toc512796780][image: ]How to Set the Default Font in Excel 2010/2013
Save time by making the fonts in your Microsoft Excel program accessible by default. Just go to File > Options > General > When Creating New Workbooks… Then choose a sans serif font such as Verdana or Arial and choose font size 12. 

Set the zoom to 100% and strive to eliminate horizontal scrolling at 100% which benefits everyone, but especially those with cognitive disabilities, those who use only a keyboard (no mouse), and those who use screen magnification. 

[bookmark: _Toc512796781]
2. TABLES: Make sure tables are simple grids with simple headers, with one per sheet.
It is important to note that different types of electronic documents (PDFs, Word documents, PowerPoint presentations, etc.) have different requirements for making tables accessible. For Excel documents, tables must be made into simple grids with simple headers. Headers are descriptive cells that describe what kind of data to expect in in a given row or column. It is often helpful to highlight headers using a different background color so that they stand out from the rest of the table.  
[bookmark: _Toc512796782]Accessible Table Structures

Accessible Scenario #1: One row of headers that describe each column: 
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Accessible Scenario #2: One column of headers that describe each row:
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Accessible Scenario #3: One row and one column of headers that describe the data at the intersection of each row and column:
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Complicated tables can be simplified to fit one of these scenarios by creatively eliminating the following inaccessible features:
[bookmark: _Toc512796783]Inaccessible Features That Need to be Removed From Tables

· More than one row of headers.
· More than one column of headers.
· Empty or merged headers.
· Merged cells anywhere in the table.
· Empty rows.
· Empty columns. 
[bookmark: _Toc512796784]
Exception: Title rows can be merged.
Every table should have a descriptive title above it. The title row can be merged and centered above the table (or centered across the selection), and is not technically considered to be part of the table. A table may have multiple title rows as shown in the example below: 
[image: ]
[bookmark: _Toc512796785]
Exception: One empty row can be inserted between vertically stacked tables.
When an Excel workbook contains multiple tables, it is best to add a new sheet for each new table. However, if needed, tables can be stacked vertically on one sheet, with one empty row inserted between each table. But avoid doing this when possible!
If you choose to have multiple tables in in a sheet, additional tweaks will be needed to make them accessible once the content is finalized. These are covered in Part 2 under TitleRegions and Named Ranges.


[bookmark: _Toc512796786]Workarounds for Blank Rows
[image: ]To create visual white space where you might have otherwise put a blank row, tweak row heights and vertical alignment as shown in in the screen shot below. Inspect the heights and alignments in rows 1 and 3:


[bookmark: _Toc512796787]Empty Data Cells
Empty data cells in tables are confusing for everyone, and it is not ideal to have them. Remember that every empty cell in a data table will be read by screen readers as ‘blank’. Consider putting something informative in empty data cells, such as: N/A or 0; or add a blanket explanation like “Blank cells indicate places where no data is available.”
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[bookmark: _Toc512796788][image: ]Added Benefit of Accessible Tables
Accessible tables not only make more sense for people zooming in with screen magnifiers and listening to the table read aloud, but they are also a lot more readable and sensible for sighted users too!


[bookmark: _Toc512796789]3. CHARTS: Make sure charts are well labeled and described, with one per sheet.
[bookmark: _Toc512796790]Labels
Labels can be added by clicking on a chart to activate the Chart Tools tabs. Click on the Layout tab and look for the Labels section. 

Add a chart title, axis titles, a legend, and data labels. Note: You may need to play with the label placement, font sizing, and chart dimensions to optimize readability.

Note: Do not use the ‘Data Table’ option on the Chart Tools Layout tab. It places the table inside the chart, which is not accessible. 

[bookmark: _Toc512796791]One chart per sheet on cell A1
After you have finished tweaking the appearance and labels of a chart, place it in a separate sheet by itself. First adjust the height and width of A1 to match the dimensions of the chart. Then paste or drag the chart to the upper left corner so that the chart floats over cell A1. 

[bookmark: _Toc512796792]Alt Text
An alternative text description (alt text) is a short description that describes an image.  To add alt text to a chart, click on the white background of the chart, right click and choose Format Chart Area. In the dialog box, click on Alt Text in the left column. Then type a short description in the Description box. Note: You can leave the title blank. It is not read by screen readers. 


[bookmark: _Toc512796793]Long Description
Since charts convey a lot of information, they also require a long description. The long description needs to describe the information available in the chart in detail for users who cannot see the chart, similar to describing a chart to someone over the phone. Long descriptions can be placed in cell A1 underneath they chart so that they are the first thing read by a screen reader. When a sighted user views the tab, they will see the chart, and when a screen reader starts reading the tab, it will read the long description cell A1 that depicts what sighted users see in the chart. The long description provides alternative access for the chart. 
It is also good practice to place the data table from which the chart was generated in A2, just below the chart and long description. When this is the case, cell A1 would be the width of the first column in the table and the chart would span across the cells in row A.

[bookmark: _Toc512796794]4. COLOR: Make sure any use of color is accessible.
All content in an Excel document needs to make sense when viewed in black and white. 
Tip: To check for color contrast and readability, print out the spreadsheets using a black and white printer.

In particular, check the following:	
· Make sure any information conveyed in color charts and images still makes sense when viewed in grayscale.

· Make sure that there is sufficient contrast between the background and foreground text in tables that make use of colored text or backgrounds. 

· Do not format negative numbers using red text. Plain red text on a white background does not meet color contrast standards for accessibility. If needed, a dark red can meet color contrast standards.

· In tables or charts, do not convey information with color alone.
For charts, data labels can help alleviate this problem, as well as using lighter and darker shades or patterns instead of all solid colors. 
The Resources section of this User Guide includes a link to a free color contrast analyzer tool.

[bookmark: _Toc512796795]5. OTHER: Check other types of content for accessibility.
There are many other types of content that can be put into Excel spreadsheets besides tables and charts. This section highlights accessibility for some of them. 
[bookmark: _Toc512796796]Text boxes & Floating Content
Text boxes and any floating content are not accessible in any of the Microsoft Office programs. Best practice is not to use these at all. One exception is charts that have been made accessible using the techniques described in this User Guide.
[bookmark: _Toc512796797]Hyperlinks
Make sure the text for each hyperlink makes sense when read out loud by itself and out of context. Screen readers can pull up a list of links for quick navigation, and each link needs to make sense when read by itself.  Example: A link for ‘Budget Table’ tells the user what the link is for, whereas a link that says ‘Click here’ or ‘view’ or ‘next’ does not. 
Also make sure that any links to external sources, such as web sites, are fully qualified. Example: A link to an online report needs to have an address that starts with “http://”.
[bookmark: _Toc512796798]Images 
All images need to have alternative text that provides a brief description of the image. If it is a complex image such as an infographic or flowchart, it will also need a long description. If it is a decorative image such as a horizontal line or a logo, the alt text should be a carriage return.
[bookmark: _Toc512796799]Excel Comments
Excel comments are not accessible because screen readers don’t read them. Data Validation input messages can be used as an accessible alternative to Excel comments because they look very similar to them, and they can also be read by screen readers.
[bookmark: _Toc512796800]Inline Dropdown Filters
Inline dropdown filters can be made accessible by providing instructions on how to access them:
· Since screen readers don’t announce when filters are present, you must add some instructions that tell users which cells have filters on them. 
· Users who only use a keyboard also need to be notified of how to access filters using only the keyboard (ALT + Down Arrow). 


[bookmark: _Toc512796801]PART 2: Final Presentation

To avoid having to re-do steps, some accessibility checks are best left until after the main content is finalized and the document is almost ready for publication or distribution. These kinds of items are covered in this section.
[bookmark: _Toc512796802][image: ]PART 2 Checklist
6.  Properties:         Turn off track changes and check document properties.
7. Named Cells:    Name the upper left cell of each table.
8. Top & Bottom:   Identify the top and bottom of each sheet.
9. Sheets & TOC:  Name sheets, delete unused sheets, and add a Table of 
                          Contents to multi-sheet workbooks.
10. Readability:       Use features to improve readability. 

[bookmark: _Toc512796803]6. PROPERTIES: Turn off track changes & check document properties
[bookmark: _Toc512796804]Track Changes
If the track changes feature has been used, make sure changes are accepted or rejected and track changes is turned off for final document distribution.
[bookmark: _Toc512796805]Document Properties
Setting document properties such as author, subject, and title, is a best practice for any document that will be distributed publically, and also contributes to search engine optimization. These properties are located under File > Info > Show All Properties. At the very least, ensure that any pre-populated properties would be appropriate if they were read by a screen reader or search engine. For example, DARS Communications would be a more appropriate author than Jane Doe.
[bookmark: _Toc512796806]Language
If the document is in a language other than English, check the language settings under File > Options. Setting the language will tell screen readers how to pronounce words. 


[bookmark: _Toc512796807]7. NAMED CELLS: Name the upper left cell of each table.
By default, spreadsheet cells have names like A1, A2, B1, B2, etc. You can also rename cells in plain English if it is helpful to do so. The JAWS screen reader takes advantage of the ability to name cells by using agreed-upon naming conventions for the upper left corner cell of data tables. First, review how to name cells in Excel.
[bookmark: _Toc512796808]Pre-requisite knowledge: How to Name a Cell
Use the following steps to name a cell: 
1. Click on the cell
2. [image: ]Click in the name box for the cell. By default it is named with a letter and number that indicate the column and row, such as B3. Change the name by typing a new name. 


































3. Press enter.
4. To verify that you have renamed the cell, click on the cell and look at the name box. It should have the correct name in it.
5. To see a list of all the cells on in a workbook that have been renamed, correct a misspelled name, or remove a name, use the Name Manager on the Formula Tab. Or use the keyboard shortcut CTRL+F3.
NAMING RULES 
No two cells can have the same name; names must be unique; spaces are not allowed.
[bookmark: _Toc512796809]Cell Naming Conventions for the JAWS Screen Reader
Best practice is use only one table per sheet in an Excel workbook. In this case, name the upper left cell of each table with one of the following naming conventions.
If a table has only column headers, start the cell name with: ColumnTitle
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If a table has only row headers, start the cell name with: RowTitle
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If a table has both column headers and row headers, start the cell name with: Title 
	[bookmark: Title2]Header
	Header
	Header
	Header

	Header
	Data
	Data
	Data

	Header
	Data
	Data
	Data

	Header
	Data
	Data
	Data

	Header
	Data
	Data
	Data


[image: ]
When  possible, design tables to have both row and column headers and name the upper left cell starting with “Title” because it is the most informative.
Example: If a contact information table contains columns for full name, address, city, state, and zip code, then it would be most informative to name the upper left cell starting with “Title”, such as “Title_Contacts”. Then JAWS will read both the column and row headers: When a JAWS user reads down any column (such as the address column), the row header (full name) will be announced before each cell value; and when the user reads across a row, the column headers will be announced before each cell value.
[bookmark: _Toc512796810]Special TitleRegion Naming Convention for Sheets with Multiple Tables
When two or more data tables are included in the same worksheet, users of assistive technology may think that cells from one table are related to cells from another table.  Therefore, best practice is to only have one table per sheet. If you really need to place two or more tables on the same sheet, leave a single blank row between each table and use the following 4-part naming convention for the upper left corner cell of each table. This naming convention is based on: the sheet number, the table number, and cell names of the upper left and lower right corners of the table:
TitleRegion#.upperleft.lowerright.sheet#
Example: If the second table on the first sheet starts in cell A21 (upper left) and ends in H28 (bottom right), then you would give cell A21 the following name: TitleRegion2.A21.H28.1
[bookmark: _GoBack]Note: Use ColumnTitleRegion# or RowTitleRegion# in the first portion of the name if the table has only column or row headers. 

[image: ]Warning: If you make changes to data tables (such as moving things around or adding or deleting rows or sheets), you may have to edit the upper left corner cell name to reflect the changes! Therefore, it’s best to wait until you are certain that the document is final and ready to publish before naming the upper left cell of your tables.



[bookmark: _Toc512796811]8. TOP & BOTTOM: Identify the top and bottom of each sheet.
[bookmark: _Toc512796812]Top of Sheet
[image: ]Make sure content starts in cell A1. Since screen readers start reading in cell A1, it makes sense that the information in your spreadsheets should start in cell A1. Otherwise, screen reader users will hear ‘blank’ for every empty cell they tab through until the actual data starts. Similarly, screen magnifier users will see magnified white empty space until they find where the data starts. 

[bookmark: _Toc512796813][image: ]Bottom of Sheet
Let screen reader users know when they have reached the end of a worksheet: After the last row of information in a sheet, press enter and type ‘End of Worksheet’ in the first cell in column A. 

[bookmark: _Toc512796814]How to Hide Content That is Only Meant for Screen Readers
If you don’t want “End of Worksheet” displayed to sighted users, make the text white on a white background. Similarly instructions at the top of the sheet can optionally be hidden from sighted users.


[bookmark: _Toc512796815]9. SHEETS & TOC: Name sheets, delete unused sheets, and add a Table of Contents to multi-sheet workbooks.

[bookmark: _Toc512796816]Naming and Deleting Sheets
Default sheet names in Excel are Sheet1, Sheet 2, etc. To give a sheet a new name, double click the name, type a new name, and press Enter. To delete an unused sheet, right click on the sheet name and choose delete.
[bookmark: _Toc512796817][image: ]Adding a Table of Contents
If you have a multi-sheet worksheet, insert a new sheet on the left and make this sheet a Table of Contents with links to the other sheets. To create, edit, or remove a link, look for Hyperlink on the Insert tab.

Example: If your spreadsheet contains a sheet of data for each month of the year, the Table of Contents sheet should have links to each of the other sheets. 


[image: ]To create a link for January, click on the Table of Contents cell containing the word ‘January’, go to the Insert Tab, and choose Hyperlink. On the left hand side of the Hyperlink dialog box, choose Place in this Document; then click on the name of the sheet containing the January data and click OK. The text ‘January’ will then become blue and underlined to indicate that it is a hyperlink.
[bookmark: _Toc512796818]10. READABILITY: Use features to improve readability.
For complex spreadsheets, consider adding instructions and/or named ranges.
[bookmark: _Toc512796819]Instructions
If a worksheet contains multiple tables or complex information, it is helpful to put instructions in A1 for screen reader users, giving a quick explanation of what is on the sheet. This serves to provide the same kind of quick context for blind users that sighted users will have when they glance at a sheet upon opening it. When writing instructions, just imagine that you can’t see the rest of the sheet and describe to the user what to expect. 
[bookmark: _Toc512796820][image: ]Named Ranges
Use named ranges to identify 1) each table on sheets that have multiple tables, or 2) logical sections that occur in lengthy tables.
A named range is similar to a named cell, except that you name a block of cells rather than just one cell. Unlike naming the upper left cell to help JAWS identify table headers, the named ranges discussed in this section are intended for humans. So when choosing a name for a block of cells, choose a meaningful human-readable name.
Consider a spreadsheet with a table of 250 rows of data, representing 25 elementary schools, where the first 10 rows of data are for one school, the second 10 rows of data are for a different school, and so on. You could define a named range for each school and then any user can quickly jump to the data for any of the elementary schools using the Name Box dropdown. For low vision and blind users who can’t quickly scan a large table, named ranges make a huge difference in being able to access information.
The steps for naming, editing, and removing named ranges are the same steps as for named cells.  If you move things around after creating a named range, it will not be automatically updated. You must manually update a named range to reflect the correct block of cells. Because of this, it’s best to add named ranges after the table content is finalized.

Long Tables
Use freeze panes on lengthy tables so that the headers will stay in place while scrolling. 
[bookmark: _Toc512796821]Printing or Saving as a PDF
For spreadsheets that will be printed or saved in a PDF format, set the print area and set print titles to repeat across pages for multi-page tables. The print area can be set and cleared from the Page Layout tab. Print titles for tables can be set using the following steps: 
1. Go to the Page Layout tab and click on Print Titles.
2. Click the icon for Rows to Repeat at Top.
3. Use the mouse to select the title/header rows on the spreadsheet that you want to be printed on every page. A blinking border will appear around the selection.
4. Click the icon again (which will return to the main page setup dialog) and click OK.

[bookmark: _Toc512796822][image: ]Optional: For added readability, hide unused rows and columns
This measure helps low vision and blind users access all the information in a workbook without getting lost navigating extraneous empty columns or rows. It also gives spreadsheets a polished look for sighted users. 

To hide unused columns:
1. Select the first empty column to the right of the content
2. Press CTRL + Shift+ Right Arrow 
3. Right click on the selected columns and choose Hide.
To unhide hidden columns:
1. Select the whole sheet in the upper left corner.
2. On the Home ribbon under Cells, click on Format.
3. Use the Visibility > Hide & Unhide options.
The same method can be used to hide/unhide rows; to select all extraneous rows, use CTRL + Shift+ Down Arrow.
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